Trying to do a Re-install Automatically
  • I'm just trying to do a Re-install automatically, to get the latest SP6.0-Beta1,
    but I'm getting the following error message.

    Upgrade WordPress

    Downloading update from http://www.semiologic.com/media/members/sem-pro/bleeding/sem-pro-bleeding.zip.

    Fatal error: Out of memory (allocated 43515904) (tried to allocate 7309580 bytes) in /home/pshanks/public_html/patandlornatesting.com/blog/wp-includes/http.php on line 1331

    Anything I should do?

    Thanks,
    --Pat
  • http://wordpress.org/extend/plugins/core-control/

    Please install that, and hop over to Tools / Core Control. Enable the HTTP module, and see what transport you are using.

    Then, try disabling them one by one, and try to re-install until you find the one that works.

    Don't forget to report back, too. So far, the one that's causing the most problems is the PHP extension, and the one with the least problems is curl.

    D.

  • @D

    As requested

    PHP HTTP Extension - Not Available
    cURL - Fatal error: Out of memory
    PHP Streams - WordPress upgraded successfully
    PHP fopen() - Failed - Incompatible archive: PCLZIP_ERR_BAD_FORMAT (-10) : Unable to find End of Central Dir Record signature
    PHP fsockopen() - WordPress upgraded successfully

    --Pat
  • @D,

    One other small problem when I click on the main Dashboard (See screen shot) I get a "Blog not found, er?"

    But if I click on the sub-menu Dashboard then the dashboard displays.

    --Pat
  • so much for curl, lol. btw, I've updated version checker today, so that it adds detailed instructions as to what to do when an core upgrade (or re-install) fails.

    thanks for reporting the akismet bug. will be fixing the admin menu sorter tonight.

  • I'm hoping that the new version checker fixes the memory error with curl -- I bump it to 128M. For the fopen() one, there isn't much I can do -- but as far as I'm aware it's very broken anyway...

    Akismet bug will be fixed the next time I update the zip (should be tonight).

  • I dont see any errors, reinstall just displays:
    Downloading update from http://www.semiologic.com/media/members/sem-pro/download/sem-pro.zip.

    I have waited for half an hour and nothing happens.

    I have the latest version checker and core control plugins.

    Pete
  • @Pete: I might have been refreshing the zip when you tried it. Can you give it another shot?

    D.

  • Sure, I tried it again but stiil the same.

    Pete
  • @Pete: please get in touch on skype or YIM tomorrow (I'm ddebernardy on both)

    D.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!